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Overview 

These release notes are for the StorageWorksTM NAS Executor 
E7000 by Compaq running version 2.0 of the NAS software 
image.  This document provides important information that is not 
covered in other documentation. 

 
IMPORTANT:  Read this entire document before installing and 
configuring the StorageWorks NAS Executor E7000. 

Software Updates 

The software that ships with the StorageWorks NAS Executor 
E7000 includes a special build of Microsoft Windows-Powered 
Operating System. Any software updates must be qualified 
against the Windows-Powered Operating System. 

 
IMPORTANT:  Install only Compaq-approved patches or service packs.

To view the list of approved patches please see the 
StorageWorks NAS Website at: 

http://www.compaq.com/storage/nas_index.html. 

NFS Logging 

The maintenance of the NFS log through the web interface to the 
E7000 does not allow the deletion of the log.  The NFS log 
delete option is located in the WebUI under Maintenance, Logs, 
NFS Log, and then clicking the Clear button.  After clicking the 
Clear button, a confirmation screen appears. After clicking OK 
to confirm the deletion, the following error message will appear:  
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"Error: There has been a sharing violation.
The source or destination file may be in use." 

The administrator can delete the log after the Server for NFS 
service is stopped. 

Be aware that this will cause a service interruption to all users 
trying to access NFS shares on the E7000. 

1. Open the web user interface to the E7000. 

2. Click Maintenance->Terminal Services and log in. 

3. Right mouse click the My Computer icon and choose 
Manage. 

4. Open the Services portion of the management tree.  

5. Select and stop the Server for NFS service.   

You can now delete the log using the web interface as 
instructed. 

6. Start the Server for NFS service. 

NFS administrative shares support 

SFU does not work with administrative shares in the same 
fashion as CIFS. By default, a volume drive such as C: is CIFS 
shared as C$. This is an example of an administrative share and 
is hidden from CIFS clients. If an NFS share is created and 
named drive$, as in the example, the share will not be hidden 
from NFS clients. This NFS share will act as a normal NFS 
share. 

Volume Mount Points support 

Attempting to create an NFS share on a disk mounted on a 
mount point will result in the error message: 

“Cannot write IOCTL to NFS driver…”.
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StorageWorks NAS Executor E7000 supports many network-
sharing protocols, including the NFS protocol for UNIX and 
Linux clients.  Shares for which the NFS protocol will be 
enabled must be created on Virtual Disks that are mounted on a 
drive letter.  Microsoft Windows-Powered OS supports 
mounting virtual disks onto mount points or reparse points 
created on another disk already mounted on a drive letter.   

Mount points enable the administrator to mount many disk 
devices under a single drive letter, creating the appearance and 
behavior of a larger disk drive with a contiguous namespace.  
However, the Microsoft Services for UNIX (SFU) NFS Server 
does not yet support the functionality of mount points.   

All virtual disks to be used for NFS sharing should be mounted 
on a drive letter, not on a reparse or mount point.  If no NFS 
shares will be created on a particular virtual disk, that virtual 
disk can be mounted on a mount point instead of a drive letter. 

User name mapping Japanese characters 

User name mapping for the network file system (NFS) server does not 
support Windows or UNIX user names containing Japanese 
characters.The name of NFS client groups that are used by the NFS 
server cannot contain Japanese characters. 

NFS Share parameters cannot be changed after 
taking a group offline 

NFS Share parameters cannot be changed after taking its group 
offline. An error will appear when attempting to edit the NFS 
parameters in this manner.  

"Error: The Path entered does not exist."

Workaround: 

NFS Share parameters can be modified if the NFS resource is 
taken offline individually, rather than as a group. 
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Take only the NFS share that you want to edit offline and then 
change parameters. 

1. Select Cluster Management from the WebUI. 

2. Click Resources. 

3. Click the radio button for the NFS resource being edited. 

4. Click Take Offline.  

5. Return to the Resources page and click the radio button for 
the NFS resource being edited. 

6. Click Parameters from the NFS resource properties page. 

7. Edit the parameters and click OK. 

8. Using Cluster Management in the WebUI, turn the NFS 
resource to online. 

Admin cannot list and map domain users and 
groups for SFU mapping unless the SFU admin 
is logged into the domain 

The administator must log into the domain before mapping 
domain users and groups. If the admin is not logged into the 
domain, the domain user or group is not on the list of Windows 
users or groups and cannot be mapped. 

Password Synchronization will not work 
correctly on a Domain Controller without an 
Admin UI 

The sfucustom.msi file located on the StorageWorks NAS E7000 
at c:\SFU does not install an Admin UI for password 
synchronization on a DC. 

The Admin UI is used to set up: 

•= Direction of password synchronization 
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•= Encryption Key 

•= Port Number 

•= Password Sync retries 

•= Unix systems to sync with 
 

NOTE:  NFS Authentication Tools and Password Synchronization can 
be installed separately or together. The instructions follow. 

To install Password Synchronization on the DC by itself (no 
NFS Authentication Tools): 

1. Allow the c:\WINNT\bin\SFU directory of the E7000 to be 
shared. 

net share SFU=C:\WINNT\bin\SFU

2. On the DC, connect to the share. 

net use Z: \\NAS_machine_name\SFU

3. Change directories from the DC to the root of the connected 
E7000 share. 

cd /d Z:\

4. Run the install program on the DC. 

OemSetup.msi ADDLOCAL=PasswdSync
SFUDIR=C:\SFU OEMINSTALL=TRUE SOURCELIST=Z:\
/l*v %temp%\sfusetup.log /q

5. Reboot the DC. 

The DC must be rebooted manually after installing the password 
synchronization piece to run correctly. 

6. Run the Admin UI on the DC and setup password 
synchronization. 

7. Click Start->Programs->Windows Services for Unix-
>Services for Unix Administration. 
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To install NFS Authentication Tools on the DC by itself (no Password 
Synchronization),Use the instructions outlined in the E7000 
Administration Guide. 

To install NFS Authentication Tools and Password 
Synchronization on the DC: 

1. Allow the c:\WINNT\bin\SFU directory of the E7000 to be 
shared. 

net share SFU=C:\WINNT\bin\SFU

2. On the DC, connect to the share. 

net use Z: \\NAS_machine_name\SFU

3. Change directories from the DC to the root of the connected 
E7000 share. 

cd /d Z:\

4. Run the install programs on the DC in the following order. 

a. OemSetup.msi ADDLOCAL=NFSServerAuth
SFUDIR=c:\SFU OEMINSTALL=TRUE
SOURCELIST=Z:\ /l*v %temp%\sfusetup.log /q

b. OemSetup.msi ADDLOCAL=PasswdSync
SFUDIR=c:\SFU OEMINSTALL=TRUE
SOURCELIST=Z:\ /l*v %temp%\sfusetup.log /q

5. Reboot the DC. The DC must be rebooted manually after 
installing the password synchronization piece to run 
correctly. 

Disconnected Client Telnet Session can cause 
the SFU GUI to hang 

If a client Telnet session is forcibly disconnected from the E7000 
while the SFU GUI is open, the SFU GUI can hang and become 
unusable. To get around this, stop the SFU GUI on the E7000 
using Task Manager and reopen the SFU GUI. 
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How to read SFU Help 

When browsing to the SFU help under the documentation menu 
branch, the browser prompts for action on downloading an 
executable. Download this self-extracting zip file and allow it to 
unzip to a temporary directory. Go to that directory and open the 
svcsunix.chm file to view the help for Microsoft SFU. 

Storage, SAN, and Switching 

LUN Identification 

To identify LUN - Pool mapping, the administrator should: 

1. Open Snapshot Manager (SWVR). 

2. Click Start->Programs->COMPAQ SANworks Virtual  
Replicator->Snapshot Manager. 

3. Select the pool. Right click and select Properties. Select the 
Storage Units tab. Note the disk number(s) in the pool. 
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4. Open Secure Path. 

5. Click Start->Programs->Secure Path->SPM. 

6. Log in to Secure Path Manager. 

7. Expand the tree by double clicking the Storage System icon 
and clicking the + sign next to the controller icon. 

All LUNs should now be present. 

8. Click View->Device Identification->WINNT->Disk 
Number. 

This view displays the disk number that correlates to the disk 
number previously noted. Make a note of where the LUN is 
located within Secure Path that you are trying to track. 
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9. Click View->Device Identification->WINNT->UUID. 

This view displays the UUID that matches the LUN ID on the 
SAN. 
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The first 16 digits refer to the WWN number of then SAN 
that the LUN resides. The last 16 digits refer to the unique 
LUN ID for that particular LUN. This number can be used to 
track the LUN back to the SAN. First track the WWN of the 
SAN. (First 16 digits if the UUID number) Keep in mind 
that all SANs have a unique WWN number and that the 
number will begin with a 6000. For example, the UUID is 
6000 1fe1 0008 2260 0009 0300 4924 0124. The WWN for 
the SAN correlates to the first 16 digits of the UUID, or 
6000 1fe1 0008 2260. However, you need to change the 
6000 to a 5000 so the WWN that you are looking for is 5000 
1fe1 0008 2260. The final step will isolate the LUN within 
the SAN, making the search simpler. 
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10. Click View->Device Identification->WINNT-
>Bus,Target,LUN. 

This view displays the target-bus-LUN for the LUNs. The last 
number, the LUN, represents the unit number on the SAN. In the 
screen below, the LUN is D1. 

 

SAN Connection Process 

The process of configuring the StorageWorks NAS E7000 with 
the correct software for a particular SAN configuration is 
accomplished via a WEB interface and an automated installation 
process. This automated process and interface do not yet account 
for updates or changes to the SAN configuration after the initial 
setup. 

 
IMPORTANT:  If it becomes necessary to make updates, corrections, or 
changes of any type to the SAN configurations originally specified in the 
SAN Connect process of the WEB interface, the existing SAN drivers and 
support software must be manually uninstalled before running the SAN 
Connect process again. 
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To make changes to the SAN specifications, the administrator 
must execute a manual process, outlined below, to remove all 
SAN drivers and support software, not just the items that are 
changing. This complete uninstall and reinstall process 
guarantees compliance with the various dependencies and load 
order rules among the software components and drivers. 

The process for changing the SAN Connection settings is 
summarized below: 

1. Verify that there is a known good backup of the NAS 
device's data. 

2. Disconnect the fiber cable or cables from the NAS device's 
HBAs. 

3. Connect to the NAS device's WEB Interface. 

(http://NASname:3201)

4. Select Maintenance from the WEB interface's left menu. 

5. Select Terminal Services to launch a console window on the 
NAS device. 

6. Log in as administrator on the console of the NAS device. 

7. Open the Control Panel using Start -> Settings->Control 
Panel. 

8. Open Add/Remove Programs. 

9. Select StorageWorks Large LUN Utility and remove it. 

10. Select Secure Path software and remove it. 

11. Select StorageWorks FC Switch or Hub support software 
and remove it. 

12. At a Run command, type: 

Regedit
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13. Navigate to the following drive: 
Hkey_Local_Machine\Software\Compaq\StorageWorks 
NAS. 

14. Set the PRSState to –1. 

15. Reboot. 

After all software is uninstalled and the system is rebooted, re-
run the SAN Connect process, as outlined below and detailed in 
the release notes section titled SAN Connection: 

1. Verify that the SAN is not connected to the fiber HBAs in 
the NAS device. 

2. Connect to the NAS device's WEB interface 
(http://NASname:3201). 

3. Select the SAN Connect item from the left menu. 

4. Answer questions about the specifics of the SAN. 

5. Monitor the automated process that installs correct software 
and reboots. 

6. Physically connect the fiber cables to the NAS device when 
prompted. 

Hub and loop switch restrictions 

Fibre channel hubs and loop switches are supported for use with 
the StorageWorks NAS Executor E7000. However, there are two 
restrictions that an administrator should be aware of. 

1. LUNs that were created using the ACS 8.5 firmware are not 
visible or manageable in SecurePath 3.1A. This means that 
SecurePath cannot be used to administer these LUNs, and 
that multiple data paths for a no single point of failure 
(NSPOF) configuration will result in multiple instances of 
the physical device. 
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To work around this, the administrator must delete all the 
LUNs created with the ACS 8.5 firmware, then re-create 
them using the ACS 8.6-1 firmware. 

2. Using SecurePath 3.1A, fibre channel arbitrated loop 
(FCAL), and ACS 8.6-1 firmware, LUNs cannot be 
numbered higher than 63. LUNs D0 through D63 are 
available for use, but LUNs D64 through D99 are not. 

Support For Enterprise Virtual Array 

To use Enterprise Virtual Array storage with the NAS Executor 
E7000, you must download a softpaq and solutions paper from 

www.compaq.com/products/storageworks/e7000/index.html 

The softpaq includes updated support software for the Enterprise 
Virtual Array;the solution paper describes how to install the 
update, and details best practices for using the Enterprise Virtual 
Array with the StorageWorks NAS Executor E7000. 

After installing the SoftPaq, return to the SAN Connection 
Wizard and finish the initialization. 

Cluster Agent Activation 

If the StorageWorks NAS Executor E7000 server is part of a 
cluster, the Compaq Insight Manager Cluster Agent must be 
activated. The Cluster Agent allows administrators to monitor 
the state of the cluster and the cluster resources from Compaq 
Insight Manager. 

To activate the agent click Start->Settings->Control Panel-
>Compaq Management Agents and add the clustering agent to 
the active agent list. 
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Cluster Setup Tool 

Cluster Setup Tool screens lose focus 

The Cluster Setup Tool  opens multiple screens during the 
process of installing cluster software. The focus can get lost 
when a new screen opens. Verify your screen by reading the 
hostname or screen title at the top of the page before proceeding 
to the next step in the Cluster Setup Tool. 

Cluster Setup Tool requires a Gateway 

The Cluster Setup Tool requires you to enter a Gateway when 
entering a static IP address. Simply copy the current IP address 
into the Gateway address field. 

Quick Restore Process 

Quick Restore Removes all Data on the local 
disks 

When Help is selected from the QR CD 1, the only text 
displayed is: 

Storage Works NAS Quick Restore - Compaq
Appliance : Storage Works NAS E7000 - Press C
to continue

After pressing C, the contents of the local drives will be erased. 
The system is then be restored to factory state using the Quick 
Restore process. 
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SANworks Virtual Replicator 

Disk Defragmenter does not work on SWVR 
volumes 

A portion of the Windows 2000 operating system related to disk 
access does not function with SWVR managed disks. This 
includes the disk defragmenter program included with Windows 
2000. 

LVM Defaults to Dynamic Disk 

Microsoft Logical Volume Manager (LVM)prompts you to 
upgrade to Dynamic disk type. Do not upgrade any Virtual 
Replicator created disks to Dynamic type. Press Cancel and 
manage your volumes. 

Network Disks 

The current NAS Executor E7000 implementation of SWVR 
does not support network disks. Do not attempt to install this 
feature on top of the NAS Executor E7000 image. 

Lifeguard and Snapshots 

Lifeguard is a service that deletes snapshots automatically when 
the amount of pool space in a pool has been exhausted. The 
Lifeguard service is a safety mechanism that prevents pool space 
depletion. If the pool's snapshot space is depleted because of a 
heavy load, blue screens and data corruption could occur. A 
snapshot should therefore be viewed as transitory because it can 
be deleted at any time without user notification. Refer to the 
StorageWorks NAS Executor E7000  by Compaq Administration 
Guide for details about the Lifeguard service. 
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Snapshots Naming 

The parent and child relationships of snapshots of other 
snapshots are not reflected in the interface. A snapshot of a 
snapshot appears as a child of the original virtual disk, instead of 
the original snapshot. Detailed naming of snapshots should be 
maintained to accurately track the relationship and to avoid 
confusion. For example, include "child of" in the snapshot name. 

SWVR and TaskScheduler 

SWVR jobs submitted to the TaskScheduler show a successful 
completion status even when underlying task was not successful. 
Administrators should enable logging on all tasks associated 
with SWVR and examine these logs for successful completion. 

SWVR uses the TaskScheduler in the Windows Powered 
Operating System for some SWVR functions. When a snapshot 
is scheduled for immediate creation, a date two days in the past 
is indicated. Logging should be enabled for all SWVR events 
through the interface option to ensure that the proper dates and 
completion criteria is reviewed. 

Tasks submitted to the TaskScheduler are retained by the 
TaskScheduler even after the underlying virtual disk is removed. 
Tasks should be cleared from the TaskScheduler before the 
deletion of a virtual disk. 
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Using Virtual Replicator with Other Windows 
Tools 

This section includes best practices and restrictions for using 
Virtual Replicator with other Windows tools, such as Disk 
Management and Cluster Administrator. 

Keep the following guidelines in mind: 

•= When there are two ways to do a task--using Virtual 
Replicator or using another tool--always use Virtual 
Replicator. For example: use Virtual Replicator to delete a 
pool in a cluster, not Cluster Administrator. 

•= Use Virtual Replicator to map drive letters to virtual disks 
and snapshots, not  to Disk Management (in Windows 2000). 

•= Do not use Windows Explorer to monitor free space in a 
pool; Windows Explorer does not recognize pools. 

•= Do not use Virtual Replicator in conjunction with the 
Windows Disk Management/Logical Disk Manager. Doing 
so can result in unpredictable behavior. 

•= Close Logical Disk Manager whenyou are using Virtual 
Replicator management tools. 

•= Do not perform Disk Management tasks on disks that are 
part of Virtual Replicator pools. 

•= Do not perform online volume growth of basic or virtual 
disks concurrently with other major disk management 
operations, such as defragmenting and disk checking. 

•= As an extra precaution, before performing any tasks with 
Disk Management, use Device Manager to scan for hardware 
changes to update disk information. 

See the Compaq SANworks Virtual Replicator System 
Administrator’s Guide for additional information on using VR. 
This guide can be found on the documentation CD. 
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Segment Size 

During SWVR pool creation, you are asked to select a Segment 
Size. The Segment Size is used to determine the largest possible 
virtual disk in a pool and the largest storage unit you can add to 
the pool. The segment size is set when a pool is created and 
cannot be changed without deleting the pool. Compaq 
recommends using 256K for the segment size. 

Allocation Unit Size 

During SWVR virtual disk creation, you are asked to select a file 
allocation unit size. One possible option is to select Default, but 
the display does not indicate that the default is set at a 16K 
allocation unit size. Compaq recommends the default 16K file 
allocation unit size. 

SWVR Driver and Windows Powered Operating 
System Issue 

The SANworksTM Virtual Replicator filter driver is not digitally 
signed. As a result, a permission issue prevents Windows from 
completing Virtual Replicator operations to create VR objects 
initiated remotely from the Web UI and from Microsoft 
Terminal Services unless the console is logged in. 

To resolve this issue, you must create the objects by accessing 
the Web UI or the VR Snapshot Manager from the server 
console using the Compaq Remote Insight Lights Out Board or if 
an actual console is connected to the server, by accessing the 
console itself. 

Alternatively, you can login and lock the console, allowing the 
Web UI or Microsoft Terminal Services to be used remotely. 

1. Connect to the server via the network and the Remote 
Insight Lights Out Board and access the server console. 

2. Log in to the console using the administrative account. 
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3. Select the CTRL-ALT-DEL button and lock the console as 
a security measure 

4. Terminate the Remote Insight Lights Out Board session. 

Compaq is working with Microsoft to resolve this issue. 

VR Namespace Recovery 

Namespace Recovery is a tool that can be used to resync VR 
objects in the Windows Registry. The current version of 
Namespace Recovery does not address the VR per pool policies. 
In the event that it becomes necessary to run Namespace 
Recovery, the per pool policy information will not be created. As 
a result, VR functionality from the Web UI will not work. You 
will need to use Terminal Service to get into the system and run 
Snapshot Manager. Compaq expects to have a patch available for 
this issue in the near future. 

The Namespace Recovery utility currently does not work with 
clustered systems. 

For more information on recovering from a disaster, see the 
Compaq White Paper: “Disaster Recovery, A Planning and 
Recovery Guide for the StorageWorks NAS Executor E7000,” 
which can be found at the following location: 

www.compaq.com/storage/nas_index.html 

NAS Web User Interface 

WebUI hangs when moving the cluster group 

If the cluster group is moved when using the WebUI from the 
Resource Groups screen, the browser screen will hang after 
clicking OK at the "Are you sure want to move the
Cluster Group?" screen. 
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The cluster group moves and the browser page needs to be 
refreshed. The page can be refreshed by clicking the WebUI 
Status screen and then returning to the Resource Groups screen. 

Loading page malfunction 

When using the Web UI, the page must load completely to 
function properly. 

When using the NAS Executor E7000 Web UI, wait for the 
entire page to load. If an object on the UI is clicked, there may 
be an error on the page, as the Javascript for the page had not 
totally initialized. 

Web UI default page may change 

Re-running either Cluster Setup Tool or Rapid Startup changes 
the default page. 

If you re-run either the Cluster Setup Tool or Rapid Startup, the 
default page is changed to something other than the status page. 
To make the status page the default again, simply press the 
Cancel button on the page. 

Terminal Services returns a VBScript error 

Terminal Services through the Web UI may cause a VBScript 
error if the client has a trust violation with the NAS Server. This 
is caused by the Internet Explorer settings. If you use an IP 
address instead of name resolution through a DNS Server, there 
will be a broken trust issue between the NAS server and the 
browser. Internet Explorer does not accept ActiveX controls 
from distrusted web sites. 

1. On the client machine, open Internet Explorer 5.5 or higher. 

2. From the menu, choose Tools->Internet Options. 
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3. Click on the Security tab, select trusted sites, and click the 
Sites button. 

4. Add your NAS Server's site to the list of trusted sites and 
save the settings. 

Your ActiveX services should now work. 

Moving an owned Cluster resource should 
report an error 

When attempting to move a resource owned by node A to a 
group owned by Node B, the Move resource page does not move 
the resource and shows no error. 

In this situation, you have two groups: group A and group B. 
Node A owns group A. Node B owns group B. As a rule, you are 
not allowed to move a resource from group A to group B when 
the groups are owned by different nodes. Doing this through 
Cluster management will result in an error. The Web UI does not 
generate an error. It also does not advance to the next page. 
Compaq is currently working to resolve this issue. 

Managing NTFS Mountpoints 

Currently, there is  no facility for managing NTFS mountpoints 
in the Web UI. To create or manage NTFS mountpoints, you 
must use Terminal Services. To start terminal services select 
Maintenance, then Terminal Services on the navigation menu. 
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CIFS incorrectly allows 'Change' selection 

The CIFS share "change" permission is not implemented 
correctly when using the WebUI Share Management Wizard. 

If you create a CIFS share using the Share Management Wizard 
and assign the user the permission of allow "change", the user 
will not have access to that folder. Allowing read, change/read, 
or full access allows the user access to the folder. 
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Microsoft Powered OS 

Event Log Messages in the Event Log 
 

During a reboot of the system when services are starting, 
dependent services may fail initially waiting for other services to 
start.  Messages will be logged to the event log and can be 
ignored as the service will restart. Messages include services 
related to:   
 
MSFTPSVC
The description for Event ID (105) in Source (MSFTPSVC) 
cannot be found. The local computer may not have the necessary 
registry information or message DLL files to display messages 
from a remote computer.  Refer to Microsoft Knowledge Based 
Article Q240779. 
 
W3SVC
The description for Event ID ( 105 ) in Source (W3SVC) cannot 
be found. The local computer may not have the necessary 
registry information or message DLL files to display messages 
from a remote computer.  Refer to Microsoft Knowledge Based 
Article Q240779. 
 
Userenv
Windows cannot determine the user or computer name. Return 
value (1722).  Refer to Microsoft Knowledge Based Article 
Q261007. 
 
Perfdisk error
WMI ADAP unable to process PerfDisk performance library due 
to a time violation in the open function. Refer to Microsoft 
Knowledge Based Article Q266416. 
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Things that will cause the cluster to fail  
•= Do not change the names of the Nodes.  This will cause the 

cluster service to fail. 

•= Do not change the name of the cluster. 

•= Do not change your public network to a private network.  
You will be unable to change this back to public.  It is a one 
time only change 

•= Do not delete the Quorum Disk.  This is used for cluster 
communication and houses the cluster database that is used 
for keeping track of all the cluster information. 

•= Do not change subnet mask on one of the nodes. 

•= Do not assign the drive letter that is used for the Quorum 
Disk to newly created virtual disks.
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